$re = '/^engine\.(.+)/m';
$str = 'engine.unreal-engine
engine.source2.arch
engine.source2.hollow-block
engine.source2.pivot-manipulation
engine.unreal-engine.best-practices
engine.unreal-engine.blueprint-interface
engine.unreal-engine.cpp-and-blueprints
engine.unreal-engine.directory
engine.unreal-engine.post-process-volume
lexicon.unreal-engine.actor
lexicon.unreal-engine.ai-controller
lexicon.unreal-engine.casting
lexicon.unreal-engine.character
lexicon.unreal-engine.component
lexicon.unreal-engine.pawn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);