import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^engine\\.(.+)";
final String string = "engine.unreal-engine\n"
+ "engine.source2.arch\n"
+ "engine.source2.hollow-block\n"
+ "engine.source2.pivot-manipulation\n"
+ "engine.unreal-engine.best-practices\n"
+ "engine.unreal-engine.blueprint-interface\n"
+ "engine.unreal-engine.cpp-and-blueprints\n"
+ "engine.unreal-engine.directory\n"
+ "engine.unreal-engine.post-process-volume\n"
+ "lexicon.unreal-engine.actor\n"
+ "lexicon.unreal-engine.ai-controller\n"
+ "lexicon.unreal-engine.casting\n"
+ "lexicon.unreal-engine.character\n"
+ "lexicon.unreal-engine.component\n"
+ "lexicon.unreal-engine.pawn";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}