// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^engine\.(.+)").unwrap();
let string = "engine.unreal-engine
engine.source2.arch
engine.source2.hollow-block
engine.source2.pivot-manipulation
engine.unreal-engine.best-practices
engine.unreal-engine.blueprint-interface
engine.unreal-engine.cpp-and-blueprints
engine.unreal-engine.directory
engine.unreal-engine.post-process-volume
lexicon.unreal-engine.actor
lexicon.unreal-engine.ai-controller
lexicon.unreal-engine.casting
lexicon.unreal-engine.character
lexicon.unreal-engine.component
lexicon.unreal-engine.pawn";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}