const regex = /^engine\.(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^engine\\.(.+)', 'gm')
const str = `engine.unreal-engine
engine.source2.arch
engine.source2.hollow-block
engine.source2.pivot-manipulation
engine.unreal-engine.best-practices
engine.unreal-engine.blueprint-interface
engine.unreal-engine.cpp-and-blueprints
engine.unreal-engine.directory
engine.unreal-engine.post-process-volume
lexicon.unreal-engine.actor
lexicon.unreal-engine.ai-controller
lexicon.unreal-engine.casting
lexicon.unreal-engine.character
lexicon.unreal-engine.component
lexicon.unreal-engine.pawn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}