#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Results_l?(.*)[-_]w(\d{2})[-_]x(\d{2})-?y(\d{2})"
Local $sString = "Results_lT026020-w01-x01-y02" & @CRLF & _
"Results_lGOLDEN-w01-x01-y02" & @CRLF & _
"Results_lT9606901A-w01-x01-y02" & @CRLF & _
"Results_lT014911R-w25-x01-y02" & @CRLF & _
"Results_T503023_w01_x01y06" & @CRLF & _
"Results_GOLDEN_w01_x01y06" & @CRLF & _
"Results_T503023R_w01_x01y06" & @CRLF & _
"Results_T503023R1_w01_x01y06" & @CRLF & _
"Results_lT972230R1-w02-x01-y02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")