// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Results_l?(.*)[-_]w(\d{2})[-_]x(\d{2})-?y(\d{2})").unwrap();
let string = "Results_lT026020-w01-x01-y02
Results_lGOLDEN-w01-x01-y02
Results_lT9606901A-w01-x01-y02
Results_lT014911R-w25-x01-y02
Results_T503023_w01_x01y06
Results_GOLDEN_w01_x01y06
Results_T503023R_w01_x01y06
Results_T503023R1_w01_x01y06
Results_lT972230R1-w02-x01-y02";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}