const regex = /Results_l?(.*)[-_]w(\d{2})[-_]x(\d{2})-?y(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Results_l?(.*)[-_]w(\\d{2})[-_]x(\\d{2})-?y(\\d{2})', 'gm')
const str = `Results_lT026020-w01-x01-y02
Results_lGOLDEN-w01-x01-y02
Results_lT9606901A-w01-x01-y02
Results_lT014911R-w25-x01-y02
Results_T503023_w01_x01y06
Results_GOLDEN_w01_x01y06
Results_T503023R_w01_x01y06
Results_T503023R1_w01_x01y06
Results_lT972230R1-w02-x01-y02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}