using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Results_l?(.*)[-_]w(\d{2})[-_]x(\d{2})-?y(\d{2})";
string input = @"Results_lT026020-w01-x01-y02
Results_lGOLDEN-w01-x01-y02
Results_lT9606901A-w01-x01-y02
Results_lT014911R-w25-x01-y02
Results_T503023_w01_x01y06
Results_GOLDEN_w01_x01y06
Results_T503023R_w01_x01y06
Results_T503023R1_w01_x01y06
Results_lT972230R1-w02-x01-y02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}