import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(?=:\\/\\/(www\\.)?(google|sougou))";
final String string = "fasuehttp://www.google.comfasdfhttp://www.baidu.comfasdhttp://sougou.comsfdhttp://www.zhihu.com";
final String subst = "https";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}