import Foundation
let pattern = #"http(?=:\/\/(www\.)?(google|sougou))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"fasuehttp://www.google.comfasdfhttp://www.baidu.comfasdhttp://sougou.comsfdhttp://www.zhihu.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)