re = /http(?=:\/\/(www\.)?(google|sougou))/m
str = 'fasuehttp://www.google.comfasdfhttp://www.baidu.comfasdhttp://sougou.comsfdhttp://www.zhihu.com'
subst = 'https'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result