import re
regex = re.compile(r"http(?=:\/\/(www\.)?(google|sougou))", flags=re.MULTILINE)
test_str = "fasuehttp://www.google.comfasdfhttp://www.baidu.comfasdhttp://sougou.comsfdhttp://www.zhihu.com"
subst = "https"
result = regex.sub(subst, test_str)
if result:
print(result)