#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\A.*?[\n\r](?=&)"
Local $sString = "Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"&HEAD CHID='PBD', TITLE='Tools'/Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"&TIME T_BEGIN=0, T_END=60/Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"Comments & Stuff" & @CRLF & _
"" & @CRLF & _
"Comments & Stuff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")