re = /\A.*?[\n\r](?=&)/m
str = 'Comments & Stuff
Comments & Stuff
&HEAD CHID=\'PBD\', TITLE=\'Tools\'/Comments & Stuff
Comments & Stuff
Comments & Stuff
&TIME T_BEGIN=0, T_END=60/Comments & Stuff
Comments & Stuff
Comments & Stuff'
# Print the match result
str.match(re) do |match|
puts match.to_s
end