import re
regex = re.compile(r"\A.*?[\n\r](?=&)", flags=re.MULTILINE | re.DOTALL)
test_str = ("Comments & Stuff\n\n"
"Comments & Stuff\n\n"
"&HEAD CHID='PBD', TITLE='Tools'/Comments & Stuff\n\n"
"Comments & Stuff\n\n"
"Comments & Stuff\n\n"
"&TIME T_BEGIN=0, T_END=60/Comments & Stuff\n\n"
"Comments & Stuff\n\n"
"Comments & Stuff")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")