$re = '/\A.*?[\n\r](?=&)/ms';
$str = 'Comments & Stuff
Comments & Stuff
&HEAD CHID=\'PBD\', TITLE=\'Tools\'/Comments & Stuff
Comments & Stuff
Comments & Stuff
&TIME T_BEGIN=0, T_END=60/Comments & Stuff
Comments & Stuff
Comments & Stuff';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);