import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A.*?[\\n\\r](?=&)";
final String string = "Comments & Stuff\n\n"
+ "Comments & Stuff\n\n"
+ "&HEAD CHID='PBD', TITLE='Tools'/Comments & Stuff\n\n"
+ "Comments & Stuff\n\n"
+ "Comments & Stuff\n\n"
+ "&TIME T_BEGIN=0, T_END=60/Comments & Stuff\n\n"
+ "Comments & Stuff\n\n"
+ "Comments & Stuff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}