using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0][x][0-9A-F]{2}[,]\s){7}[0][x][0-9A-F]{2}$";
string input = @"0x28, 0x30, 0x57, 0x45, 0xD4, 0xCD, 0x0F, 0xAD";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}