package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[0][x][0-9A-F]{2}[,]\s){7}[0][x][0-9A-F]{2}$`)
var str = `0x28, 0x30, 0x57, 0x45, 0xD4, 0xCD, 0x0F, 0xAD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}