$re = '/^(?:[0][x][0-9A-F]{2}[,]\s){7}[0][x][0-9A-F]{2}$/';
$str = '0x28, 0x30, 0x57, 0x45, 0xD4, 0xCD, 0x0F, 0xAD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);