const regex = /^(?:[0][x][0-9A-F]{2}[,]\s){7}[0][x][0-9A-F]{2}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0][x][0-9A-F]{2}[,]\\s){7}[0][x][0-9A-F]{2}$', 'g')
const str = `0x28, 0x30, 0x57, 0x45, 0xD4, 0xCD, 0x0F, 0xAD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}