#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)DEBUG.*job_id='([^']*)'"
Local $sString = "output line from channel: [2021-11-14 15:59:20] config='954'!" & @CRLF & _
"output line from channel: [2021-11-14 15:59:21] DEBUG: job_name='test' disabled=true" & @CRLF & _
"output line from channel: [2021-11-14 15:59:25] DEBUG: job_id='a185' configsized"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")