import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "DEBUG.*job_id='([^']*)'";
final String string = "output line from channel: [2021-11-14 15:59:20] config='954'!\n"
+ "output line from channel: [2021-11-14 15:59:21] DEBUG: job_name='test' disabled=true\n"
+ "output line from channel: [2021-11-14 15:59:25] DEBUG: job_id='a185' configsized";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}