use strict;
my $str = 'output line from channel: [2021-11-14 15:59:20] config=\'954\'!
output line from channel: [2021-11-14 15:59:21] DEBUG: job_name=\'test\' disabled=true
output line from channel: [2021-11-14 15:59:25] DEBUG: job_id=\'a185\' configsized';
my $regex = qr`DEBUG.*job_id='([^']*)'`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}