re = /DEBUG.*job_id='([^']*)'/m
str = 'output line from channel: [2021-11-14 15:59:20] config=\'954\'!
output line from channel: [2021-11-14 15:59:21] DEBUG: job_name=\'test\' disabled=true
output line from channel: [2021-11-14 15:59:25] DEBUG: job_id=\'a185\' configsized'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end