package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)DEBUG.*job_id='([^']*)'`)
var str = `output line from channel: [2021-11-14 15:59:20] config='954'!
output line from channel: [2021-11-14 15:59:21] DEBUG: job_name='test' disabled=true
output line from channel: [2021-11-14 15:59:25] DEBUG: job_id='a185' configsized`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}