# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"DEBUG.*job_id='([^']*)'"
test_str = ("output line from channel: [2021-11-14 15:59:20] config='954'!\n"
"output line from channel: [2021-11-14 15:59:21] DEBUG: job_name='test' disabled=true\n"
"output line from channel: [2021-11-14 15:59:25] DEBUG: job_id='a185' configsized")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.