#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(( [\{] (\{|\})|[\{] (\{|\})), |,( [\{] (\{|\})|[\{] (\{|\})))"
Local $sString = "{" & @CRLF & _
" "id": "123456"," & @CRLF & _
" "group1": {" & @CRLF & _
" "Value1": "abc"," & @CRLF & _
" "group2": [{ }, { }, { }, { }]," & @CRLF & _
" "group3": [{ }, { }, { }, { }, {" & @CRLF & _
" "phone number": 988888," & @CRLF & _
" "country": "india"" & @CRLF & _
"" & @CRLF & _
" }]" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")