using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(( [\{] (\{|\})|[\{] (\{|\})), |,( [\{] (\{|\})|[\{] (\{|\})))";
string input = @"{
""id"": ""123456"",
""group1"": {
""Value1"": ""abc"",
""group2"": [{ }, { }, { }, { }],
""group3"": [{ }, { }, { }, { }, {
""phone number"": 988888,
""country"": ""india""
}]
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}