$re = '/(( [\{] (\{|\})|[\{] (\{|\})), |,( [\{] (\{|\})|[\{] (\{|\})))/m';
$str = '{
"id": "123456",
"group1": {
"Value1": "abc",
"group2": [{ }, { }, { }, { }],
"group3": [{ }, { }, { }, { }, {
"phone number": 988888,
"country": "india"
}]
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);