package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(( [\{] (\{|\})|[\{] (\{|\})), |,( [\{] (\{|\})|[\{] (\{|\})))`)
var str = `{
"id": "123456",
"group1": {
"Value1": "abc",
"group2": [{ }, { }, { }, { }],
"group3": [{ }, { }, { }, { }, {
"phone number": 988888,
"country": "india"
}]
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}