import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(( [\\{] (\\{|\\})|[\\{] (\\{|\\})), |,( [\\{] (\\{|\\})|[\\{] (\\{|\\})))";
final String string = "{\n"
+ " \"id\": \"123456\",\n"
+ " \"group1\": {\n"
+ " \"Value1\": \"abc\",\n"
+ " \"group2\": [{ }, { }, { }, { }],\n"
+ " \"group3\": [{ }, { }, { }, { }, {\n"
+ " \"phone number\": 988888,\n"
+ " \"country\": \"india\"\n\n"
+ " }]\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}