re = /(( [\{] (\{|\})|[\{] (\{|\})), |,( [\{] (\{|\})|[\{] (\{|\})))/m
str = '{
"id": "123456",
"group1": {
"Value1": "abc",
"group2": [{ }, { }, { }, { }],
"group3": [{ }, { }, { }, { }, {
"phone number": 988888,
"country": "india"
}]
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end