#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/\*\s*<!\[CDATA\[[\s\S]*?\/\*\s*\]\]>\s*\*\/"
Local $sString = "<script type="text/javascript">" & @CRLF & _
" /* <![CDATA[ */" & @CRLF & _
" var A=new Array();" & @CRLF & _
" .........................." & @CRLF & _
" .........................." & @CRLF & _
"/* ]]> */" & @CRLF & _
"</script>" & @CRLF & _
"some text2 ........................" & @CRLF & _
"some text3 ........................" & @CRLF & _
"some text4 ........................" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
" /* <![CDATA[ */" & @CRLF & _
" var B=new Array();" & @CRLF & _
" .........................." & @CRLF & _
" .........................." & @CRLF & _
"/* ]]> */" & @CRLF & _
"some text5 ........................"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)