const regex = /\/\*\s*<!\[CDATA\[[\s\S]*?\/\*\s*\]\]>\s*\*\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*\\s*<!\\[CDATA\\[[\\s\\S]*?\\\/\\*\\s*\\]\\]>\\s*\\*\\\/', 'g')
const str = `<script type="text/javascript">
/* <![CDATA[ */
var A=new Array();
..........................
..........................
/* ]]> */
</script>
some text2 ........................
some text3 ........................
some text4 ........................
<script type="text/javascript">
/* <![CDATA[ */
var B=new Array();
..........................
..........................
/* ]]> */
some text5 ........................`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);