# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*\s*<!\[CDATA\[[\s\S]*?\/\*\s*\]\]>\s*\*\/"
test_str = ("<script type=\"text/javascript\">\n"
" /* <![CDATA[ */\n"
" var A=new Array();\n"
" ..........................\n"
" ..........................\n"
"/* ]]> */\n"
"</script>\n"
"some text2 ........................\n"
"some text3 ........................\n"
"some text4 ........................\n"
"<script type=\"text/javascript\">\n"
" /* <![CDATA[ */\n"
" var B=new Array();\n"
" ..........................\n"
" ..........................\n"
"/* ]]> */\n"
"some text5 ........................")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.