re = /\/\*\s*<!\[CDATA\[[\s\S]*?\/\*\s*\]\]>\s*\*\//
str = '<script type="text/javascript">
/* <![CDATA[ */
var A=new Array();
..........................
..........................
/* ]]> */
</script>
some text2 ........................
some text3 ........................
some text4 ........................
<script type="text/javascript">
/* <![CDATA[ */
var B=new Array();
..........................
..........................
/* ]]> */
some text5 ........................'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result