import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*\\s*<!\\[CDATA\\[[\\s\\S]*?\\/\\*\\s*\\]\\]>\\s*\\*\\/";
final String string = "<script type=\"text/javascript\">\n"
+ " /* <![CDATA[ */\n"
+ " var A=new Array();\n"
+ " ..........................\n"
+ " ..........................\n"
+ "/* ]]> */\n"
+ "</script>\n"
+ "some text2 ........................\n"
+ "some text3 ........................\n"
+ "some text4 ........................\n"
+ "<script type=\"text/javascript\">\n"
+ " /* <![CDATA[ */\n"
+ " var B=new Array();\n"
+ " ..........................\n"
+ " ..........................\n"
+ "/* ]]> */\n"
+ "some text5 ........................";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}