using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\D)|(?<=^))(0+)(?=[1-9]+)|((?<=\D0)0+(?=\D))|((?<=^0)0+(?=\D*$))";
string input = @"0.txt
t001.txt
001.txt
00100.txt
0000.txt
001
00100
0000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}