import Foundation
let pattern = #"((?<=\D)|(?<=^))(0+)(?=[1-9]+)|((?<=\D0)0+(?=\D))|((?<=^0)0+(?=\D*$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0.txt
t001.txt
001.txt
00100.txt
0000.txt
001
00100
0000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)