const regex = new RegExp('((?<=\\D)|(?<=^))(0+)(?=[1-9]+)|((?<=\\D0)0+(?=\\D))|((?<=^0)0+(?=\\D*$))', 'g')
const str = `0.txt
t001.txt
001.txt
00100.txt
0000.txt
001
00100
0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}