import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=\\D)|(?<=^))(0+)(?=[1-9]+)|((?<=\\D0)0+(?=\\D))|((?<=^0)0+(?=\\D*$))";
final String string = "0.txt\n"
+ "t001.txt\n"
+ "001.txt\n"
+ "00100.txt\n"
+ "0000.txt\n\n"
+ "001\n"
+ "00100\n"
+ "0000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}