re = /((?<=\D)|(?<=^))(0+)(?=[1-9]+)|((?<=\D0)0+(?=\D))|((?<=^0)0+(?=\D*$))/
str = '0.txt
t001.txt
001.txt
00100.txt
0000.txt
001
00100
0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end