use strict;
my $str = '0.txt
t001.txt
001.txt
00100.txt
0000.txt
001
00100
0000';
my $regex = qr/((?<=\D)|(?<=^))(0+)(?=[1-9]+)|((?<=\D0)0+(?=\D))|((?<=^0)0+(?=\D*$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}