#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iuxm)^" & @CRLF & _
"((http|https):)?(?(1)//|.)# protocol" & @CRLF & _
"(([\.\pL\pN-]+:)?([\.\pL\pN-]+)@)?# basic auth" & @CRLF & _
"(" & @CRLF & _
" ([\pL\pN\pS\-\.])+(?(1)\.?|\.)([\pL\pN\pS\-\.])+|((?(1)\.?|\.)([\pL\pN]|xn\-\-[\pL\pN-]+)+\.?)# domain name" & @CRLF & _
" | \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}# ip address" & @CRLF & _
")" & @CRLF & _
"(:[0-9]+)?# port" & @CRLF & _
"(?:/ (?:[\pL\pN\-._\~!$&'()*+,;=:@]|%[0-9A-Fa-f]{2})* )*# path" & @CRLF & _
"(?:\?(?:[\pL\pN\-._\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# query" & @CRLF & _
"(?:\# (?:[\pL\pN\-._\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# fragment" & @CRLF & _
"$"
Local $sString = "localhost.fhgf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")