package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^
((http|https):)?(?(1)//|.)# protocol
(([\.\pL\pN-]+:)?([\.\pL\pN-]+)@)?# basic auth
(
([\pL\pN\pS\-\.])+(?(1)\.?|\.)([\pL\pN\pS\-\.])+|((?(1)\.?|\.)([\pL\pN]|xn\-\-[\pL\pN-]+)+\.?)# domain name
| \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}# ip address
)
(:[0-9]+)?# port
(?:/ (?:[\pL\pN\-._\~!$&'()*+,;=:@]|%[0-9A-Fa-f]{2})* )*# path
(?:\?(?:[\pL\pN\-._\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# query
(?:\# (?:[\pL\pN\-._\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# fragment
$`)
var str = `localhost.fhgf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}