const regex = new RegExp('^
((http|https):)?(?(1)//|.)# protocol
(([\\.\\pL\\pN-]+:)?([\\.\\pL\\pN-]+)@)?# basic auth
(
([\\pL\\pN\\pS\\-\\.])+(?(1)\\.?|\\.)([\\pL\\pN\\pS\\-\\.])+|((?(1)\\.?|\\.)([\\pL\\pN]|xn\\-\\-[\\pL\\pN-]+)+\\.?)# domain name
| \\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}# ip address
)
(:[0-9]+)?# port
(?:/ (?:[\\pL\\pN\\-._\\~!$&\\'()*+,;=:@]|%[0-9A-Fa-f]{2})* )*# path
(?:\\?(?:[\\pL\\pN\\-._\\~!$&\\'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# query
(?:\\# (?:[\\pL\\pN\\-._\\~!$&\\'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# fragment
$', 'ium')
const str = `localhost.fhgf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}