using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s@]+@[^\s@]+\.[^\s@]+$";
string input = @"prettyandsimple@example.com
ryan+bar@gmail.com
verycommon@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
#!$%&'*+-/=?^_`{}|~@example.org
""()[]:,;@\\\""!#$%&'*+-/=?^_`{}| ~.a""@example.org
"" ""@example.org
üñîçøðé@example.com
üñîçøðé@üñîçøðé.com
Pelé@example.com
δοκιμή@παράδειγμα.δοκιμή
我買@屋企.香港
甲斐@黒川.日本
чебурашка@ящик-с-апельсинами.рф";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}