import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s@]+@[^\\s@]+\\.[^\\s@]+$";
final String string = "prettyandsimple@example.com\n"
+ "ryan+bar@gmail.com\n"
+ "verycommon@example.com\n"
+ "very.common@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "other.email-with-dash@example.com\n"
+ "#!$%&'*+-/=?^_`{}|~@example.org\n"
+ "\"()[]:,;@\\\\\\\"!#$%&'*+-/=?^_`{}| ~.a\"@example.org\n"
+ "\" \"@example.org\n"
+ "üñîçøðé@example.com\n"
+ "üñîçøðé@üñîçøðé.com\n"
+ "Pelé@example.com\n"
+ "δοκιμή@παράδειγμα.δοκιμή\n"
+ "我買@屋企.香港\n"
+ "甲斐@黒川.日本\n"
+ "чебурашка@ящик-с-апельсинами.рф";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}