import re
regex = re.compile(r"^[^\s@]+@[^\s@]+\.[^\s@]+$", flags=re.MULTILINE)
test_str = ("prettyandsimple@example.com\n"
"ryan+bar@gmail.com\n"
"verycommon@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-dash@example.com\n"
"#!$%&'*+-/=?^_`{}|~@example.org\n"
"\"()[]:,;@\\\\\\\"!#$%&'*+-/=?^_`{}| ~.a\"@example.org\n"
"\" \"@example.org\n"
"üñîçøðé@example.com\n"
"üñîçøðé@üñîçøðé.com\n"
"Pelé@example.com\n"
"δοκιμή@παράδειγμα.δοκιμή\n"
"我買@屋企.香港\n"
"甲斐@黒川.日本\n"
"чебурашка@ящик-с-апельсинами.рф")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")